"we are unable to update your Facebook status from Identi.ca"

"we are unable to update your Facebook status from Identi.ca"

Issue ID:1767
Issue Category:bug
Component:facebook
Priority:normal
Status:fixed
Assigned:zach
Milestone:0.8

The facebook application sometimes has an error, and emails the identica user this message:
"Hi, Identi.ca. We're sorry to inform you that we are unable to update your Facebook
status from Identi.ca, and have disabled the Facebook application for your account.
This may be because you have removed the Facebook application's authorization, or
have deleted your Facebook account. You can re-enable the Facebook application and
automatic status updating by re-installing the Identi.ca Facebook application.

Regards,

Identi.ca"

Legacy Data

This issue was migrated from another tracking system. The legacy data at time of import is provided below as a reference.

Ticket ID: 
1767
Reported by: 
candrews
Owner: 
zcopley
Status: 
closed
Resolution: 
closed
Type: 
bug
Component: 
facebook
Priority: 
3
Version: 
undefined
Milestone: 
0.8

Updates

#1

Someone with access to the identica logs needs to grep for "Facebook returned error code" and "Unable to update Facebook status for". I can't reproduce this issue on my laconica install... so I'm dead in the water until someone gets back to me with logs.

#2

I hope I've fixed this in 0.8.x (see commit b9cf19a). The update hasn't made it to Identi.ca yet. What I /think/ is happening is that Facebook is returning some undocumented errors with codes > 250. Stupidly (lazily) I was removing the FB app in the event of any error >= 200. The logs aren't going to be tremendously helpful, because I forgot to log the error code in addition to the message sent back from FB (also fixed). My attempt at a solution is to explicitly check for the two codes (200, 250) where we probably should remove the FB app, and do nothing otherwise.

See: http://wiki.developers.facebook.com/index.php/Users.setStatus#Example_Re...

#3

Any idea when you guys plan to push this to identica? Or better yet, release 0.8.1? There's a lot of changes in there now.

#4

Okay, the error we're seeing in identi.ca's logs is:

"340 Feed action request limit reached."

I forgot we're publishing to the user's stream now instead of updating his/her status. The error is documented, here:

http://wiki.developers.facebook.com/index.php/Stream.publish

So the aforementioned fix /should/ solve the problem. However, I think we may also need to ask for a different/additional permission in order to solve this problem. When publishing to streams, the limit is 10 items per day unless the user has granted the app the "offline_access" extended permission. That's why we're seeing the error.

see: http://wiki.developers.facebook.com/index.php/Feed.publishUserAction

#5

So if we request the "offline_access" permission and get it, then this problem goes away you think?

#6

@candrews: Yes, I think so.

#7

Blasted.
"You may not request multiple permissions at the same time."
http://wiki.developers.facebook.com/index.php/Desktop_App_Auth_Process

So we'll have to prompt the user twice for permissions, which sucks...

#8

This has been fixed in 0.8.1.

Login or Register to modify this issue, or to receive updates by email.

You can also subscribe to the RSS feed for updates to this issue.