Suspected bug in group creation leads to 'nameless' groups.

Suspected bug in group creation leads to 'nameless' groups.

Issue ID:3125
Issue Category:bug
Component:core
Priority:normal
Status:active
Assigned:mymmn
Version:1.0
Keywords:patch exists

Does not seem to be happening consistently, but occasionally creating a group can lead to an unnamed shadow group.
You can verify this on your installs with a sql query
select * from local_group where nickname is NULL

Updates

#1

some symptoms:

  • on identi.ca they all seem to have group URL 'http://identi.ca/group'
  • following a link (from a user's profile) for such a group (apparently by name) you end up at that URL (where you can find them)
  • from the groups list you can actually join them (by id? - they are listed with id info in the groups list)
  • they all seem to be created by (would-be) spammers, most likely using a faulty group creation script; often there are several similar nameless groups immediately followed by a similar named group

#2

one case outlined here (with screenshots):
http://identi.ca/notice/70592867 followed by
http://identi.ca/conversation/68298114#notice-70592961

#3

This is still happening in version 1.0.1. It is when you get a validation error when creating a group. The database entries still get added even though there was something wrong with the entry.

#4

Is this the same case? http://status.net/open-source/issues/3127
"Group created despite bad nickname"

I posted this solution there, and will make a merge request for Gitorious now:
"I tried adding a return; statement in actions/newgroup.php on line 128 (inside the catch{} for Nickname::normalize, to make it behave just as the rest of the tests below.

This solves the problem and doesn't regress any functionality."

#5

Version:0.9» 1.0

This merge request fixes it without any other messing around:

https://gitorious.org/statusnet/mainline/merge_requests/2233

#6

Merge request with patch for the added return statement is published at https://gitorious.org/statusnet/mainline/merge_requests/2233

#7

Assigned to:evan» mymmn
Keywords:+patch exists

#8

(Sorry…, this might be solved)

Login or Register to modify this issue, or to receive updates by email.

You can also subscribe to the RSS feed for updates to this issue.